Chevrolet Cruze Forums banner
1 - 20 of 21 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 · (Edited)
hello,
i'v 2011 cruze AT transmation with broken speedometer with check engin led turned on .
i'd tested 2 front wheel sensors but it is well.
also the transmation shaft has a problem coz the speedo broken
maybe someone met this problem be4.
thanks
regards
 

·
Lyrical Wordsmith
Joined
·
6,748 Posts
Yes, i am sure some of us had (spiking speedometer randomly being one of them). Your best bet is to take your car to the dealer and get it fixed. It sounds electrical. And complicated.

Is your car under warranty? What model is it? Where are you from? Do you have access to a code scanner, maybe if you provide us with a code it will also help out.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Yes, i am sure some of us had (spiking speedometer randomly being one of them). Your best bet is to take your car to the dealer and get it fixed. It sounds electrical. And complicated.

Is your car under warranty? What model is it? Where are you from? Do you have access to a code scanner, maybe if you provide us with a code it will also help out.
thanks dear for reply
i live in Egypt and my experiance with chevorlet not much .unfortunately i have no scanner for this brand.
but i assume that if the speedometer works ,the gear shaft will work also coz the both is related
i'm a garage owner and the car out warranty .
here is VIN maybe insight someone which cruze i'm talking about :KL1PJ5C60AK504912
thanks
regards
 

·
Resident Forum Drunkard
Joined
·
9,274 Posts
Yo Kermit you have been properly introduced to the newest smurfette from Egypt ..just do not tell any one you know very well about her...good luck to you SOFY...
 

·
Lyrical Wordsmith
Joined
·
6,748 Posts
SOFY, here is a list of links of other members having similiar problems, do some research:

http://www.cruzetalk.com/forum/25-service-issues/3564-speedometer-spiking-up-120-while-stopped.html

http://www.cruzetalk.com/forum/25-s...stabilitrak-traction-control-speedometer.html

^^^ says its a fuse, which it could very well be



Yo Kermit you have been properly introduced to the newest smurfette from Egypt ..just do not tell any one you know very well about her...good luck to you SOFY...
LOL Strong beer is strong
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Hello,
i'd updated my scanner last night (X431) now i'm able to diagnose this car.
i'd found in transmation fault :speed sensor
after erasing it the check engin goes OFF and the speedometer works well and gear shafting well also.
few kilometers of run by the car for test and the speedometer dead again.after diagnosis i found no any fault in BCM,engine,or even dash panel.
my worker pulled out the plug of transmation module (which is fitted inside the transmation box,i can access the plug only) and put it back ,the speedo works and then the same....
now my worker try to dissamble the gearbox to inspecting the module inside maybe has a cold soldering points in the plug pins
thanks
regards
 

·
Administrator
Joined
·
25,596 Posts
Hello,
i'd updated my scanner last night (X431) now i'm able to diagnose this car.
i'd found in transmation fault :speed sensor
after erasing it the check engin goes OFF and the speedometer works well and gear shafting well also.
few kilometers of run by the car for test and the speedometer dead again.after diagnosis i found no any fault in BCM,engine,or even dash panel.
my worker pulled out the plug of transmation module (which is fitted inside the transmation box,i can access the plug only) and put it back ,the speedo works and then the same....
now my worker try to dissamble the gearbox to inspecting the module inside maybe has a cold soldering points in the plug pins
thanks
regards
Definitely the way to start troubleshooting this one. Are the rest of the console displays having problems? Also, since the Cruze has both digital and "analog" speed displays, are you having problems with both the digital and "analog" speedometers or just one or the other? Answering these questions would give you some feel for where the problem lies.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #11 ·
sir ,
i think maybe cruze with big disply can showing digital speedo but in my case the cluster has a small disply which has no digital speedo,
now i'm looking for used BCM and will clone the original BCM to used one to start the car and check ,coz maybe fault in BCM.
i have no choice but still looking in junk about used one
thanks
regards

Cruze dash.jpg
 

·
Resident Forum Drunkard
Joined
·
9,274 Posts
I guess she is telling us that the us sent all of the bugs to Egypt !
MY best guess is the voltages are spiking some where in those particular circuits that talk to the transmission .
Volt checks are in order here , fused links first . Possible trans flash also...
 

·
Premium Member
Joined
·
522 Posts
sofy, what code was set?

does the vehicle do a guage sweep when you turn the key?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #15 ·
sofy, what code was set?

does the vehicle do a guage sweep when you turn the key?
no dash sweep when turn the key .
about the code if you ment fult codes which reads by scanner ,i haven't GM specialist scanner .i just have a launch X431 (update it last night specially to diagnosis this car) and read fault code in transmation (speed sensor fault) and i'd cleared it allready and the check engine led goes off.
but if you mean code showing in cluster .yes cluster disply showing CODE95 which i think this code related airbag coz it ON led also
thanks
regards
 

·
Premium Member
Joined
·
522 Posts
Service manual states that the DTC must be fixed before further diagnostics are done. Without knowing which speed sensor code you have, it's hard to help you. I have access to global Cruze service procedures so if you can get a code I may be able to help you. Should start with a "P".
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #17 ·
Sorry guy's for delay ...
it solved by replacing the BCU.
i just bought used one with same s/n and read the original dump from original BCU then write it to the used one.car starts ok ,but with some problems with beam,elec window ...etc
i sent it to dealer workshop for program this problems and now all is very well,and my clint is satisfied.
thanks all for all who tryed to help me.
thanks for all
regards
 

·
Resident Forum Drunkard
Joined
·
9,274 Posts
Thank you for the update Sofy !

Now join the Masses in any discussion of your choice .
Do not be a stranger sister !
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #19 ·
Thank you for the update Sofy !

Now join the Masses in any discussion of your choice .
Do not be a stranger sister !
dear sir,
i'm man and my real name is Hossam,
sofy just my nick online and it's related my young daughter
thanks sir for your warm welcome to me
reagrds
 
1 - 20 of 21 Posts
Top