Chevrolet Cruze Forums banner

21 - 33 of 33 Posts

·
Registered
Joined
·
32 Posts
Hey has anyone figured out what the 3 LEDs on the sides do? None of the videos of the technostalgia versions show them lit.
 

·
Premium Member
Joined
·
7,927 Posts
I gotta say, as much as I like the sequential turn signal, the brake lights bug me. I understand the idea of getting attention, but I think my first reaction isn't "brake!" but "WTF?". But I'm guessing there's no options to this?
 

·
Registered
Joined
·
32 Posts
Yup, they are just side lights. They are on when the headlights or parking lights are on. They're not supposed to do anything fancy.
That's what I'd figure but out of any video or picture I've seen they have never been on, I'm starting to think they don't do anything at all. Can someone with these installed confirm with a picture/video what these do? I'm talking about the technostalgia versions only.
 

·
Registered
Joined
·
611 Posts
Hey Danny, I hate to bring this thread back from the dead, but the reverse bulb on the passenger side trunk lid seems to have burnt out. Do you know what the replacement bulb would be (stock is fine)? I'd like to have it before I go taking my truck apart again. Thanks in advance! P.S. almost 4 years later and I still have people coming up along side of me raving about how awesome my tail-lights are. I love em!
 

·
Premium Member
Joined
·
851 Posts
Discussion Starter #28
No worries.

They are the same as the stock bulbs. I was running some high power LED replacement bulbs for a while. (921 style)
 

·
Registered
Joined
·
611 Posts
No worries.

They are the same as the stock bulbs. I was running some high power LED replacement bulbs for a while. (921 style)
Thanks for the reply Danny! I've got one more question for you. I changed out the reverse bulb (921) and the light did nothing (still dead). I noticed that the trunk lid assembly is basically dead (the other one on the same side works like a charm). I unlock the car, nothing. I use the turn signal, nothing (only half of the sequential works; not very sequential). Any ideas on what could be going on here? I've heard some horror stories about these lights, but this is my first issue since I've owned them. The wires look to be all connected and such. Is it possible that a bulb is burnt out in the other light it's tied too? I'm at a loss. I don't want to lose these lights. They really set it out from the crowd and I've gotten so many complements!
 

·
Premium Member
Joined
·
851 Posts
Discussion Starter #31
Thanks for the reply Danny! I've got one more question for you. I changed out the reverse bulb (921) and the light did nothing (still dead). I noticed that the trunk lid assembly is basically dead (the other one on the same side works like a charm). I unlock the car, nothing. I use the turn signal, nothing (only half of the sequential works; not very sequential). Any ideas on what could be going on here? I've heard some horror stories about these lights, but this is my first issue since I've owned them. The wires look to be all connected and such. Is it possible that a bulb is burnt out in the other light it's tied too? I'm at a loss. I don't want to lose these lights. They really set it out from the crowd and I've gotten so many complements!
Sorry for the delay! Feel free to hit me up on messenger if you're looking to get more instant feedback :p

tbh, if the whole assembly is dead, I am suspecting a wire fault. The good news is it's easy to diagnose. All you need is a voltmeter. ****, I got mine from harbor freight for $7.99.

Remove the reverse bulb from it's socket, and put your voltmeter testing leads in there. If it's getting power, you'll see the 12v when your helper puts the car in reverse. You could probably test the brake leads the same way.

It's very suspicious that both brake lights AND reverse lights are out, especially when the reverse light is *just* a bulb.
 

·
Premium Member
Joined
·
851 Posts
Discussion Starter #32
I remember past post saying there were a lot of issues with these lights when it was cold. Does anybody know if they got the problem fixed?
First off, they don't make these anymore.
Second, not aware of a cold weather bug with these lights. Currently it's 85-90 in my garage when I leave for work, and 110 or so when I drive home. Even in the winter the coldest my car has ever seen is mid 30s, and never noticed an issue.

YMMV
 

·
Registered
Joined
·
277 Posts
Thanks. I didn't realize they no longer made them. The issues where when it got below zero, as I recall. I like the lights, but they are pricey. IF you can't buy them, I guess it doesn't really matter anyway. LOL
 
21 - 33 of 33 Posts
Top