Chevrolet Cruze Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
Back in February I upgrade the suspension to a Bilstein coilovers. During the install i looked at the plastic swaybar end links and thought to myself these won't last long and I was right about 2 months ago a rattle started coming from the front of my car. I drove around for a month before changing the end links. After i changed the end links the noise went away, but recently a knocking/rattling has returned.

I only hear the knocking/rattling at low speeds and starts/stops.

Will a bad end link wipe out a sway bar bushing?

Any help would be great.

Thanks
 

·
Registered
Joined
·
133 Posts
Discussion Starter #3
The end links are brand new I replaced them about a month ago. I checked the end links and they are tight.
Generally I hear the noise at low speed, below 30 MPH. On real flat surfaces it doesn't make any noise, but as soon as the surface becomes remotely uneven I can hear the noise.
 

·
Registered
Joined
·
33 Posts
I think the knocking/rattling at low speeds and starts/stops was the upper strut mounts on the earlier models. I can say the slight noise I had is officially gone now thanks to the Whiteline lower control arm bushings. I also have the Whiteline (cut-to-length) front end links, #23255.

When my car did make the noise I figured it was the weak OEM suspension considering I had the dreaded "chevy lean" on the driver's side. Maybe try getting an alignment and see if they'll let you or at least a ballast that equals your weight & normal carry load are in the vehicle while it's being done.
 
1 - 5 of 5 Posts
Top