Chevrolet Cruze Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Hi all,

Just changed the timing belt on my wifes 2010 cruze 2.0 diesel.
One problem I ran into was the belt never lined up with the fuel pump? When I took the old belt off I noticed the marks didn't line up. Thought that maybe the belt had stretched and moved on..
Put the new belt on and still the marks don't line up.
Changing the pump one belt tooth just made the line marks on the opposite side.

Car is back together and seems to drive fine. My only concern is that when I took the original belt off I didn't pay attention to what side the marks where out..

Cam and crank where locked into position during change with the appropriate tools.

Is this normal or is something out of whack in the car?

Thanks!!

https://goo.gl/photos/iuiMt9s3SYHaBRBQ8
 

·
Premium Member
Joined
·
4,652 Posts
Hi all,

Just changed the timing belt on my wifes 2010 cruze 2.0 diesel.
One problem I ran into was the belt never lined up with the fuel pump? When I took the old belt off I noticed the marks didn't line up. Thought that maybe the belt had stretched and moved on..
Put the new belt on and still the marks don't line up.
Changing the pump one belt tooth just made the line marks on the opposite side.

Car is back together and seems to drive fine. My only concern is that when I took the original belt off I didn't pay attention to what side the marks where out..

Cam and crank where locked into position during change with the appropriate tools.

Is this normal or is something out of whack in the car?

Thanks!!

https://goo.gl/photos/iuiMt9s3SYHaBRBQ8
I wish I could help. The dealer did mine. What part of the world are you from? I know there are various diesel engines used in our Cruzes across the globe, but likely your setup is different than what's on my car.
 

·
Premium Member
Joined
·
5,535 Posts
Hi all,

Just changed the timing belt on my wifes 2010 cruze 2.0 diesel.
One problem I ran into was the belt never lined up with the fuel pump? When I took the old belt off I noticed the marks didn't line up. Thought that maybe the belt had stretched and moved on..
Put the new belt on and still the marks don't line up.
Changing the pump one belt tooth just made the line marks on the opposite side.

Car is back together and seems to drive fine. My only concern is that when I took the original belt off I didn't pay attention to what side the marks where out..

Cam and crank where locked into position during change with the appropriate tools.

Is this normal or is something out of whack in the car?

Thanks!!

https://goo.gl/photos/iuiMt9s3SYHaBRBQ8
If it is the same as most new diesel designs, the pump drive pulley position is meaningless.....it is only spinning a pump.

Rob
 
1 - 3 of 3 Posts
Top