Chevrolet Cruze Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a Chevrolet Cruze 2014 and have a reoccurring problem with my temperature sensor.AC shuts off frequently,I have replaced the sensor several times.can anyone assist with an alternate and permanent solution? It?s getting very frustrating
 

·
Moderator
Joined
·
2,170 Posts
Welcome to the forum! How many miles are on the car, and what trim level? (LS, LT, LTZ, Eco, Diesel) Do you have a check engine light? If so, have you had the codes read?
 

·
Super Moderator
Joined
·
5,171 Posts
Welcome, as chevrasaki said let us know a little more about what is going on codes etc. along with type of car. As you said replaced sensor several times, tells me that is probably not the problem. I would be looking at possible with the interior switch or the compressor itself.
 

·
Moderator
Joined
·
10,712 Posts
Welcome to the forums is the message you getting a Snowflake with a backslash through it and the words "A/C Off Due to High Engine Temp."?

What sensor are we replacing, the one on the bottom left of the bumper?
 

·
Administrator
2014 LT program car, Pull Me Over Red
Joined
·
12,172 Posts
Welcome Aboard!:welcome:

Is it possible you are turning the AC on and off without realizing it. Does the little green light go off (or on) after pushing a button?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top