Chevrolet Cruze Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello again Everyone,

Back in June I was having some issues with my Cruze. Had codes for a vacuum leak, and lean bank codes, etc.

Basically, I ended up replacing the cam cover/PCV valve. I did not replace the intake manifold at this time as I figured I'd try to just get away with the cheaper part, although I did not actually look to see if the check valve in the manifold was gone.

Anyway, as of recently, when braking, using turn signals, changing from park to drive or reverse or any gear, using windows...when using these 'features' the car will flash a few warning lights. Service StabiliTrak comes up on the small screen between the tachometer and speedometer. The traction control light also comes on, a break warning light pops up and also the ABS light. Lastly, and this only happened once for about 10 seconds, power steering had completely cut out while driving on the highway.

Hoping someone could point me in the right direction again...and also if anyone has any idea if these issues could be related to not replacing the intake manifold from my previous issue.

Thanks in advanced for the help!
 

Attachments

·
Registered
Joined
·
269 Posts
i have my hazards go on when
- door is opened
- aggressively brake
- shift into reverse

the service stabilitrak, or traction light does NOT come on

it is annoying and would like to know if this is a "feature" or indicative of another issue

2012 Eco manual
 

·
Administrator, Resident Tater Salad
Joined
·
17,353 Posts
Hello again Everyone,

Back in June I was having some issues with my Cruze. Had codes for a vacuum leak, and lean bank codes, etc.

Basically, I ended up replacing the cam cover/PCV valve. I did not replace the intake manifold at this time as I figured I'd try to just get away with the cheaper part, although I did not actually look to see if the check valve in the manifold was gone.

Anyway, as of recently, when braking, using turn signals, changing from park to drive or reverse or any gear, using windows...when using these 'features' the car will flash a few warning lights. Service StabiliTrak comes up on the small screen between the tachometer and speedometer. The traction control light also comes on, a break warning light pops up and also the ABS light. Lastly, and this only happened once for about 10 seconds, power steering had completely cut out while driving on the highway.

Hoping someone could point me in the right direction again...and also if anyone has any idea if these issues could be related to not replacing the intake manifold from my previous issue.

Thanks in advanced for the help!
Sounds like it's time for the negative battery cable special warranty coverage for your car.
 

·
Administrator, Resident Tater Salad
Joined
·
17,353 Posts
i have my hazards go on when
- door is opened
- aggressively brake
- shift into reverse

the service stabilitrak, or traction light does NOT come on

it is annoying and would like to know if this is a "feature" or indicative of another issue

2012 Eco manual
I have heard of aggressively braking turning them on, but not on the Cruze. And neither of mine ever did.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thank you everyone! I confirmed this with Chevy so since it's covered we're going to have them replace it. Didn't think a battery cable could cause so many issues, but it makes sense.

It's going in on Tuesday, hopefully driving it until then won't be an issue. But I will follow up and let everyone know if that solved the issue. But the Service Advisor sounded just as confident as @jblackburn does so i'm hoping that cures it.
 
1 - 6 of 6 Posts
Top