Chevrolet Cruze Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi all,
just joined this forum after searching some info related to a weird symptom happening to my 2010 cruze 2.0L.
So, after discovering a sequence of malfunctions i took my car to dealership with syptoms like 1.) boot wont open not even from remote 2.) auto light sensor not working 3.) rear brake lights off except the upper brake light 4.) rear red main lights off 5.) traction control switch interior light went off but TC works since I cam see icon on dash panel. 6.) cigarette lighter not working. 7.) windscreen wash not working
Dealership diagnosed and quoted me the price to replace the BCM but it takes 3 wks to arrive. I asked for a discount and faster shipping but still waiting on that.
The weird part is this:
Friend of mine suggested to take a look at fuse box, the interior one. So, cutting the story short, discovered when removing fuse no.3 (named BCM, the 25Amp one) all the 7 malfunctions above starts working fine(i just did not check the cig. lighter). However new problems now evolve, associated with the missing fuse no.3 like right front indicator stopped working and more noticeable other things.

My question is this... could there be a kind of electrical short somewhere (like cig. lighter) and the BCM is fine ? or the BCM is acting weird and needs replacement?
Any opinion matters because i still cant swallow well the fact that it i have a faulty BCM on just 34k Km from new.

Thank you
 

·
Premium Member
Joined
·
8,003 Posts
What happens if you put the fuse back in? Have you tried disconnecting the battery for a few minutes to allow the car to completely reboot?

It does sound like the BCM is really confused, but it could be the victim, not the perpetrator.
 

·
Premium Member
Joined
·
5,535 Posts
Mileage is meaningless to any electronic component.....they live or die just because. No rhyme or reason.

So far, I'm in agreement with the diagnosis however I would be trying to find a used one from a dismantler.

Rob
 

·
Premium Member
Joined
·
25,596 Posts
The BCM sits on the floor of the passenger compartment. Open the passenger side interior kick plate - it's clipped on and take a look. If it's wet inside dry it out with a combination of a towel and hair dryer. Unplug the BCM and clean and dry the contacts. Reassemble and see if the car is behaving again.

On other thought, the BCM is very sensitive to power problems. How old is your battery?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
The BCM sits on the floor of the passenger compartment. Open the passenger side interior kick plate - it's clipped on and take a look. If it's wet inside dry it out with a combination of a towel and hair dryer. Unplug the BCM and clean and dry the contacts. Reassemble and see if the car is behaving again.

On other thought, the BCM is very sensitive to power problems. How old is your battery?
Battery is just months old... had a battery issue months ago but after that car behaved all fine for months.
Will disconnect and check the BCM and follow your lead although I have instructed the dealership to order and replace which should be done in a week time now.
 

·
Premium Member
Joined
·
8,003 Posts
No I did not replace the 25A fuse since it is not faulty.Fuse looks fine
Fuses can fail in such a way that they look fine.

I'm looking at the scheamtics for the 2013 US Cruze, but none of this makes sense. I'd suggest tracing why the power outlets don't work. They're powered from the "Retained accessory" relay, runs though a fuse (one per outlet) and to the outlet. Pretty simple. It might be a unrelated problem, but it should be simple to trace and see if you can find the problem
 

·
Registered
Joined
·
998 Posts
Hi all,
just joined this forum after searching some info related to a weird symptom happening to my 2010 cruze 2.0L.
So, after discovering a sequence of malfunctions i took my car to dealership with syptoms like 1.) boot wont open not even from remote 2.) auto light sensor not working 3.) rear brake lights off except the upper brake light 4.) rear red main lights off 5.) traction control switch interior light went off but TC works since I cam see icon on dash panel. 6.) cigarette lighter not working. 7.) windscreen wash not working
Dealership diagnosed and quoted me the price to replace the BCM but it takes 3 wks to arrive. I asked for a discount and faster shipping but still waiting on that.
The weird part is this:
Friend of mine suggested to take a look at fuse box, the interior one. So, cutting the story short, discovered when removing fuse no.3 (named BCM, the 25Amp one) all the 7 malfunctions above starts working fine(i just did not check the cig. lighter). However new problems now evolve, associated with the missing fuse no.3 like right front indicator stopped working and more noticeable other things.

My question is this... could there be a kind of electrical short somewhere (like cig. lighter) and the BCM is fine ? or the BCM is acting weird and needs replacement?
Any opinion matters because i still cant swallow well the fact that it i have a faulty BCM on just 34k Km from new.

Thank you
Have you had the recall for the 2010 2.0l diesel BCM applied?
 
1 - 15 of 15 Posts
Top