Chevrolet Cruze Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
647 Posts
Discussion Starter · #1 ·
I am 10.0 to 1 at W.O.T. with my water/meth on.
i was told that is way to rich and 11 to 1 would be better or even a mid 11.
Looking for your number and input
 

·
Registered
Joined
·
1,166 Posts
I run between 13 to 1 to 12.5 to 1 Thats 5000 rpm up to 6000 with 12.5 being at 6000

93 octane tune. Factory tuning is about 10 to 1 at 6000 rpm
 

·
Registered
Joined
·
647 Posts
Discussion Starter · #4 ·
Vince says my 10.o afr is ok but in the same sentience he said he would like it closer to 11 to 11.4. i have been bugging him to change it but he says he needs to turn off EGT protection. i am fine with that just want a better afr to stop missing
 

·
Premium Member
Joined
·
4,339 Posts
Factory mapping includes both (a) POWER enrichiment for increasing HP output as well as (b) COOLING enrichment for TEMPERATURE "rise" due to turbocharging/compression increase.
 

·
Registered
Joined
·
285 Posts
im not sure running a 10.0 AFR will cause you to "miss". it will take power sure, but it can be seen also as a preventative measure. Running rich will decrease combustion temps, and be "easier" on the engine then running lean. I've never heard of a motor blowing up because it was too rich. I have seen motors go into melt downs from running lean. GM tuned these cars for fuel economy and reliability, not for power. My cruze is stock. However, my toy, my supercharged 2004 Sunfire using 91 octane premium runs at 14.7 when cruising, 13.1 to 13.4 to 1 when "on it" til 3500rpm, then 11.1 to 11.6 to 1 from then on up to red line. This all of course has to do with weather and air temps that day as well.

Just saying. Also, your mods (to me) don't make it sound like you NEED the h20/meth kit. Why do you run that? That alone will make your AFR's richen up close to 1 full point.
 

·
Registered
Joined
·
647 Posts
Discussion Starter · #7 ·
cause i see 1500to 1600* egts at 24psi and weather i have my 93 tune in or my water/meth tune in i still see afr of 10. with the meth on i was seeing some heavy duty miss fires up top after talking to snow performance about the system they asked what my afr was. I told them 10 to 10.2 and he said that is way to rich and i should go up to 12 to 1. i told him about the egt protection and he understood and said well at least get the afr into the 11's that is why you are missing so hard up top when spray is on. also the water/meth really helps for long pulls when racing.
 

·
Registered
Joined
·
647 Posts
Discussion Starter · #10 ·
the kit is MAF sensor controlled...come on about 2800rpm or what ever the load is on the maf sensor. yes i need to be leaned out and than add in the w/m to get an 11 afr...that what i want. 10 is to rich.
 

·
Registered
Joined
·
1,166 Posts
I would lower the boost to 21 and try 12 or 11 to 1 and see how it runs.I think your trying to run to much boost to begin with.if your driveing egt temps that high.
 

·
Registered
Joined
·
647 Posts
Discussion Starter · #12 ·
i have question my boost before cause i see 23 to 24 psi all the time...but he says is cause i am below sea level. i would be hapy with 21 22 psi
 

·
Registered
Joined
·
118 Posts
None of you said what gear you check your afrs in. From my experience it was always done just like a dyno pull, which is the gear right at 1:1. The lower gears will run leaner and each upshift should show richer.
 

·
Registered
Joined
·
408 Posts
None of you said what gear you check your afrs in. From my experience it was always done just like a dyno pull, which is the gear right at 1:1. The lower gears will run leaner and each upshift should show richer.
Usually 3rd gear has always hit the spot for me. But you're dead on in what you said.
 

·
Registered
Joined
·
647 Posts
Discussion Starter · #15 ·
auto. and i see 10 at any rpm and wot only. thru all gears it will stay at 10 the whole time up to 141mph
 

·
Registered
Joined
·
647 Posts
Discussion Starter · #16 ·
ok Vine updated me with EGT off and i was able to pull a 11.1 afr in all gears at WOT
 

·
Registered
Joined
·
647 Posts
Discussion Starter · #18 ·
very good and no missing. did log and sent in...waiting to hear back
 
1 - 18 of 18 Posts
Top