Chevrolet Cruze Forums banner

1621 - 1640 of 1678 Posts

·
Registered
Joined
·
119 Posts
I've had the brisk plugs in there for about two years, but they got corroded by the oem coil pack. They've performed great.

I noticed a small change in the gap with the new ones. They seem to be a little crisper in performance.

Weird bits? You mean the end of the plug?
 

·
Registered
Joined
·
459 Posts
Had stuttering issues and found corrosion on the plugs and oem coil pack.

Just installed the MSD performance coil pack and fresh brisk racing EVO plugs. Installed some Hella headlamps while I had the hood up

Hesitation is gone! Running like a champ!

Current config:
K&N typhoon
Borla S Type exhaust
Brisk plugs
AMS oil/ trans
MSD Coil
Trifecta tune
Pioneer touchscreen w/backup cam
Pics!!
 

·
Registered
2012 Cruze Eco 6 Speed
Joined
·
342 Posts
Pics of the exhaust, lights and coil pack. Please forgive the poor photo quality and the dirt
The headunit dash kit does it color match the factory trim ?
 

·
Premium Member
2013 Cruze LT
Joined
·
1,430 Posts
Weekend plans, UGH! Leaky leaky water outlet. O’reilly’s is next day shipping me one though and a gallon of dexcool for under $50.
288527
 

·
Premium Member
2013 Cruze LT
Joined
·
1,430 Posts
I briefly smelled coolant in the cabin, duhn duh duhn duh daaaa
I’ve been smelling it after I pull into the garage for a month or so, just put a sharpie mark on the tank and see it has went down ever so slightly... did some looking today with my new harbor freight LED light and boom, oil cooler is orange too from the drips..
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
9,350 Posts
I’ve been smelling it after I pull into the garage for a month or so, just put a sharpie mark on the tank and see it has went down ever so slightly... did some looking today with my new harbor freight LED light and boom, oil cooler is orange too from the drips..
I just detailed the engine bay and it was fine. I know I have a grip, but I was nice to her...
 

·
Registered
Joined
·
588 Posts
Weekend plans, UGH! Leaky leaky water outlet. O’reilly’s is next day shipping me one though and a gallon of dexcool for under $50. View attachment 288527
Hey bro, you might have the hose attached wrong. I pulled mine back to show you. You can see on the connection where the hose should reach. The hose should say "UP" at the 12 position and you do not want to go past that mark on the side.

You need to rotate yours to the right and pull it back a little. Line up the mark.

Looks like your cam cover is leaking also.
 

Attachments

·
Registered
Joined
·
251 Posts
Weekend plans, UGH! Leaky leaky water outlet. O’reilly’s is next day shipping me one though and a gallon of dexcool for under $50. View attachment 288527
I'm looking at replacing the coupling between the WOH & Reservoir Hose (upper). Slight leak, like 2 years ago, looks like a cracked coupling. Hopefully, I don't destroy the hose, while I'm fighting to unclip the hose from the coupling.
 

·
Premium Member
2013 Cruze LT
Joined
·
1,430 Posts
Hey bro, you might have the hose attached wrong. I pulled mine back to show you. You can see on the connection where the hose should reach. The hose should say "UP" at the 12 position and you do not want to go past that mark on the side.

You need to rotate yours to the right and pull it back a little. Line up the mark.

Looks like your cam cover is leaking also.
Interesting, I have not touched this since owning the car... So the white mark should line up with that stop? and I agree it is shoved on too far, not sure that would cause a leak though, maybe?


Cam cover is likely fine, I think thats orange dexcool. It was replaced by dealer like 4k miles ago. I'll go do a taste test if you'd like ;)
 

·
Premium Member
2013 Cruze LT
Joined
·
1,430 Posts
Maybe I should start my own thread, but after pulling that line in question back, I dont see a crack, and don't see that stop where you shouldn't push the line past... Maybe it's an aftermarket outlet? Unsure. @Shroomie
 

·
Registered
Joined
·
588 Posts
Maybe I should start my own thread, but after pulling that line in question back, I dont see a crack, and don't see that stop where you shouldn't push the line past... Maybe it's an aftermarket outlet? Unsure. @Shroomie
This is my original, it was pushed up over too.. that stop is almost gone lol. Today I'm reassembling everything.

I also found my intake manifold gasket was leaking.

Knock sensor is covered in oil

It's also 100 times easier to install the cam cover with the intake removed. You can line it up perfectly without folding or crimping the gasket. Don't need to come in at an angle and get caught on the wiring
 

Attachments

·
Premium Member
2013 Cruze LT
Joined
·
1,430 Posts
Got the water outlet job completed, oddly enough the outlet wasn't cracked... but the hose was shoved on too far and bunched up. Makes me wonder if I need a new hose also.. Anyway, leak free for now! You can see the coolant and crust on the last pic where it had been leaking.

288614


288615


288616


288617
 
  • Like
Reactions: Ravenkeeper

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
9,350 Posts
This is my original, it was pushed up over too.. that stop is almost gone lol. Today I'm reassembling everything.

I also found my intake manifold gasket was leaking.

Knock sensor is covered in oil

It's also 100 times easier to install the cam cover with the intake removed. You can line it up perfectly without folding or crimping the gasket. Don't need to come in at an angle and get caught on the wiring
No more pictures of your fingers butt crack.... You've been warned!
 
1621 - 1640 of 1678 Posts
Top