Chevrolet Cruze Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi i need help, i have a Chevrolet Cruze 2017 model 1.6 LS. The problem with it is having i Hard Start sometimes we have to push it in order the engine run, we changed the battery but still this problem persists.

It also have an oil leak so is showing engine light and spanner in the speedometer.

So i need advise, what should i do

  • Because i even take it to the service Thursday last week but they didnt not pick anything wrong
 

·
Premium Member
Joined
·
5,010 Posts
Where do you take it for servicing? What is the Warranty offered in your Country, many 2017's are still under the G.M guarantee. How many miles do you have?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I take it to GM but they told me that there is not warry related so i took it to another approved dealer...... Becaue they were cheapper than GM
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
7,898 Posts
Hi i need help, i have a Chevrolet Cruze 2017 model 1.6 LS. The problem with it is having i Hard Start sometimes we have to push it in order the engine run, we changed the battery but still this problem persists.

It also have an oil leak so is showing engine light and spanner in the speedometer.

So i need advise, what should i do

  • Because i even take it to the service Thursday last week but they didnt not pick anything wrong
What are the codes? Post them here for a more complete diagnosis.
 
1 - 8 of 8 Posts
Top