Chevrolet Cruze Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
2015 LTZ RS..
So I ordered up the ZZP DP and mid pipe combo with hi flo cat. Installed it this morning, very straight forward. Hardest part was 1 bold on the stock DP. When put it together I noticed the mid pipe was 2 pieces now instead of the old one piece older style. I noticed the Hi flo cat was super close to the Axle boot and thought Huh, that doesn't look to safe... but plenty of folks have it so must be ok. Well I started it up to checked for leaks and all was good. Test drive time... went for a short drive around home town and started to smell burning oil or something.. figured it was from welding and my hand oils or whatever. After 5 mile it got bad... and now i felt and heard the car making grinding noise... I pull over and open the hood and find grease all over. I drive home a mile away. I let it coll down and start the un install.

So end result, the Hiflo cat on the mid pipe was so close to the axle boot, it hit the boot ring and grease covered my engine bay and new exhaust. all the items are removed and I have to wait till Tuesday for the dealership to see if they will fix it. I'm not happy with my first ZZP experience. :angry::angry::angry:
 

Attachments

·
Premium Member
Joined
·
5,535 Posts
2015 LTZ RS..
So I ordered up the ZZP DP and mid pipe combo with hi flo cat. Installed it this morning, very straight forward. Hardest part was 1 bold on the stock DP. When put it together I noticed the mid pipe was 2 pieces now instead of the old one piece older style. I noticed the Hi flo cat was super close to the Axle boot and thought Huh, that doesn't look to safe... but plenty of folks have it so must be ok. Well I started it up to checked for leaks and all was good. Test drive time... went for a short drive around home town and started to smell burning oil or something.. figured it was from welding and my hand oils or whatever. After 5 mile it got bad... and now i felt and heard the car making grinding noise... I pull over and open the hood and find grease all over. I drive home a mile away. I let it coll down and start the un install.

So end result, the Hiflo cat on the mid pipe was so close to the axle boot, it hit the boot ring and grease covered my engine bay and new exhaust. all the items are removed and I have to wait till Tuesday for the dealership to see if they will fix it. I'm not happy with my first ZZP experience. :angry::angry::angry:
Chevrolet will likely repair it as long as nothing is said about the mod.

In theory though, they would not be required to repair a failure caused by a non factory component.

In the future, go with your first thought......it was indeed, too close.

Rob
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #4 ·
You may want to try to install everything loose, then check and make clearances, and then tighten. I would for sure contact ZZP too.
That's how I installed it... hung everything, then tighten after clearance adjusted. I left as much slack in that area that was allowed. To add.. I had to drill out the 2 holes on the mid pipe section that mounts to the stock resi flange. The holes were to small for the stock studs.
 

Attachments

1 - 4 of 4 Posts
Top